Windows users cannot use SMB file service to access?

SMB, AFP, NFS, FTP, WebDAV, Rsync
User avatar
TMSupport
TerraMaster Team
Posts: 2314
Joined: 13 Dec 2019, 15:15

Windows users cannot use SMB file service to access?

Post by TMSupport » 09 Dec 2021, 10:29

Troubleshooting

Applicable models: all TNAS models

Common causes and solutions for abnormal SMB access:

Reason 1: Using \\IP in the file management of Windows prompts "Windows cannot access the target".
Image
Solution:
1. Go to TOS system >control panel >CIFS/SMB file service, check and enable the SMB file service;
Image
2. Go to Windows >Control Panel >Programs and Features, enable the SMB client.
Image

Reason 2: When filling in user information, the window always prompts "The user name or password is incorrect".
Image
Solution: Exclude the situation that the username and password you entered are correct, then it may be that there is an "&" symbol in the password, please change the password.

Reason 3: Windows prompts that SMB1 version is not supported when using SMB service to access.
Solution: Go to TOS system >control panel >CIFS/SMB File Service > Advanced, switch the maximum SMB version to SMB3.
Image

Reason 4: When opening the network drive mapped by SMB on Windows, it prompts "An error occurred while reconnecting".
Image
Solution: The user's password in the mapped drive has been changed. Go to Windows > Control Panel > Credential Manager> Windows Credentials, remove the TNAS user credentials, disconnect the original network mapped drive and remap with the new user information.
Image

Reason 5: Windows prompts that multiple users are not allowed to access when using SMB service to access.
Image
Solution:
1. Disconnect the SMB network drive of Windows.
2. Delete the TNAS user stored in the Windows credential manager.
3. Use Windows + R to enter "cmd" to open the DOS window, enter net use * /del /y to clear the connected SMB user cache, and try to access the NAS again.
Image

Reason 6: The workgroup in control panel > CIFS/SMB File Service is empty.
Image
Solution: Please enter "workgroup" or a domain name that you know is in use on your computer. If it doesn't work, there may be an error in the configuration file of the Samba file service, please contact our tech team to check it remotely.

Reason 7: The password uses special characters.
Image
Solution: Change the password to one without special characters.

Reason 8: TNAS is an arm architecture device, which has samba cache on TOS.
Solution:
Try to clear the samba cache of old account or guest account on TOS.
1. go to TOS - Control Panel - User - guest - edit - Advanced Settings, check the " Disable this user account"-"Immidiately",and click "Apply".
2. go to TOS - Control Panel - File Services, disable SMB/CIFS service
3. restart TNAS, then go to TOS - Control Panel - File Services, enable SMB/CIFS service.
4. perform the "Case 5" steps once.
5. if steps 1,2,3 do not work, disable the SMB/CIFS service again.
6. Log in to SSH and switch to root privileges, enter the following command in SSH to manually clear the samba cache on TOS:viewtopic.php?f=78&t=2350

Code: Select all

cd /var/lib/samba/
rm account_policy.tdb group_mapping.tdb share_info.tdb

7. Enable SMB/CIFS service.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
Photon
Posts: 1
Joined: 08 Dec 2021, 00:23

Re: Windows users cannot use SMB file service to access?

Post by Photon » 10 Dec 2021, 07:41

I need to do Reason 3, but I see no "advanced" option. Model F2-210. TOS version 4.2.17-2110301418. At "SMB/CIFS File Service" I've checked "Enable SMB/CIFS File Service," I entered my Workgroup name, and I checked "Enable log transmission". The screen is blank below that until the shaded area "Notes" where it says "To use SMB File service, please enter the following address in Windows File Explorer \\192.168.0.98."

How do I switch the maximum SMB version to SMB3?

User avatar
TMSupport
TerraMaster Team
Posts: 2314
Joined: 13 Dec 2019, 15:15

Re: Windows users cannot use SMB file service to access?

Post by TMSupport » 10 Dec 2021, 17:31

{L_BUTTON_AT}Photon

Hi! For F2-210, the default version of SMB service is SMB3, and the SMB version cannot be modified. Please make sure that the workgroup name is entered correctly and the SMB client of Windows has been enabled.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
Photon
Posts: 1
Joined: 08 Dec 2021, 00:23

Re: Windows users cannot use SMB file service to access?

Post by Photon » 12 Dec 2021, 04:03

Thanks for the quick reply. I verified my workgroup name is entered correctly. When I enable SMB1.0/CIFS Client, the TNAS appears under Network in Windows Explorer. My Windows 10 Windows Features list doesn't include "SMB Direct" under "SMB 1.0/CIFS File Service Support" as shown in your instructions.

User avatar
Threadmiser
Posts: 0
Joined: 14 Dec 2021, 09:56

Re: Windows users cannot use SMB file service to access?

Post by Threadmiser » 14 Dec 2021, 09:58

I'm in the same boat with the F2-210. I cannot get Windows File Explorer to access it. It's giving me the password error, but there is not an "&" in my password and I've already reset it once. Any guidance on what to do would be appreciated.

User avatar
TMSupport
TerraMaster Team
Posts: 2314
Joined: 13 Dec 2019, 15:15

Re: Windows users cannot use SMB file service to access?

Post by TMSupport » 14 Dec 2021, 17:45

{L_BUTTON_AT}Threadmiser

Hi! Please make sure the username and password you entered are correct. You can set a simple password to test whether it can be connected normally.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
Threadmiser
Posts: 0
Joined: 14 Dec 2021, 09:56

Re: Windows users cannot use SMB file service to access?

Post by Threadmiser » 18 Dec 2021, 08:28

The password is definitely correct. I can log in normally to my server through the online service, but not through File Explorer.

User avatar
TMroy
TerraMaster Team
Posts: 2544
Joined: 10 Mar 2020, 14:04

Re: Windows users cannot use SMB file service to access?

Post by TMroy » 18 Dec 2021, 10:36

Please try to activate the SMB 1.0 option on your computer.
To contact our team, please send email to following addresses, remember to replace (at) with @:
Support team: support(at)terra-master.com (for technical support only)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
Tricky
Posts: 225
Joined: 07 Feb 2020, 02:12

Re: Windows users cannot use SMB file service to access?

Post by Tricky » 18 Dec 2021, 16:33

I have come to the conclusion that there is something odd about the way SMB works either down to windows or TOS I can set up the connection as it should with all the correct details and the TNAS will not be seen yet a couple of days later it will be visible with no changes and then only to vanish again.

User avatar
TMRyan
TerraMaster Team
Posts: 815
Joined: 01 Dec 2020, 11:50

Re: Windows users cannot use SMB file service to access?

Post by TMRyan » 18 Dec 2021, 18:12

{L_BUTTON_AT}Tricky
Do you mean that the TNAS is no longer visible after a few days after the computer restarts?
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement)

Post Reply