Terra Photos

More about TOS 5 new features and improvements. Note: this forum is not for bug report! If you want to report bug, please go to the correct forum.
User avatar
PhilWojo
Posts: 2
Joined: 18 Aug 2022, 04:12

Re: Terra Photos

Post by PhilWojo » 24 Aug 2022, 01:28

Ok, thanks for that, I kind of found that after I posted, but took some digging so glad you confirmed for me. Not ideal for me, but I just got my 1st ever NAS so live and learn.

User avatar
eeeney
Posts: 1
Joined: 29 Aug 2022, 03:46

Re: Terra Photos

Post by eeeney » 31 Aug 2022, 08:06

For Face AI to process/run, do I need to refresh the Media Index in TOS control panel?

I ask because if I select/enable media indexing in the control panel, then select 'apply', the page refreshes and media indexing is no longer selected/applied. No indexing seems to happen.

Media Indexing was running previously, but hasn't run for 5 days and will not stay selected.

User avatar
TMnorah
Administrator
Posts: 83
Joined: 17 Aug 2021, 09:51

Re: Terra Photos

Post by TMnorah » 31 Aug 2022, 10:26

Hi, what is your system version? and please log in to the terminal through ssh and copy some logs ,and then send them to our technical support email:
how to log in ssh

Log of media index:

Code: Select all

cp -r /var/log/media.log /Volume1/public/
Copy the logs of the media index database:

Code: Select all

cp -r /var/log/mediadb/mediadb.log /Volume1/public/
Then go to the public directory and pull it down.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
runrunrun2022
Posts: 3
Joined: 05 Sep 2022, 13:46

Re: Terra Photos

Post by runrunrun2022 » 05 Sep 2022, 13:53

Hi All,

My TOS 5 App Center does not have Terra Photos as an option to install. What is the process to get Terra Photos installed on the NAS?

User avatar
TMSupport
Customer Service
Posts: 2145
Joined: 13 Dec 2019, 15:15

Re: Terra Photos

Post by TMSupport » 05 Sep 2022, 18:47

{L_BUTTON_AT}runrunrun2022

What is the TOS version you have installed? Please keep it up to date.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
runrunrun2022
Posts: 3
Joined: 05 Sep 2022, 13:46

Re: Terra Photos

Post by runrunrun2022 » 09 Sep 2022, 08:25

{L_BUTTON_AT}runrunrun2022
TMSupport wrote:
05 Sep 2022, 18:47
What is the TOS version you have installed? Please keep it up to date.
My TOS version is 5.0.123 which as per the system states its the latest, i have the F2-221 NAS. Can you please confirm what i can do to download the App?

User avatar
TMSupport
Customer Service
Posts: 2145
Joined: 13 Dec 2019, 15:15

Re: Terra Photos

Post by TMSupport » 09 Sep 2022, 18:18

{L_BUTTON_AT}runrunrun2022

If you updated to 5.0.123 from the beta version, now you need to reinstall the official version 5.0.166. After that you can search for TerraPhotos in the app center.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
freman
Posts: 8
Joined: 30 Nov 2021, 11:26

Re: Terra Photos

Post by freman » 14 Sep 2022, 10:22

I'm gonna give up on terra photos for now.

It's quite unreliable, extremely slow, and did I mention quite unreliable.

```
[84651.023193] mediaindex[14600]: segfault at 91 ip 00007fdf1446937a sp 00007fdf0bea9a90 error 4 in libpq.so.5.13[7fdf14457000+42000]
[84651.023215] Code: 8a ff ff 48 83 c4 20 5b 5d 41 5c c3 c3 48 85 ff 0f 84 9e 00 00 00 41 55 41 54 55 53 48 83 ec 18 48 89 fb 31 ed 4c 8d 6c 24 08 <48> 8b bb 90 00 00 00 3b ab 98 00 00 00 7d 39 4c 63 e5 4d 6b e4 28
```

User avatar
JayBlingham
Posts: 107
Joined: 04 Oct 2020, 10:34

Re: Terra Photos

Post by JayBlingham » 26 Sep 2022, 18:51

I 100% agree. I've really been trying to give it a fair shot but sending me a billion emails last night telling me the "media index is complete" was the last straw.

It did manage to complete an index of my nearly 50,000 pictures (roughly 82GB), and I was able to see the photos in the "Public" tab, but it was extremely slow to load even the first page of those photos and was completely unusable. I even gave it the benefit of the doubt and enabled the AI recognition to see if I could at least get those albums to work, which should (in theory) cause only a subset of the photos to load. I gave that over 5 days to run, and maybe it's because I'm running an older model (F5-221) but it always just kept saying "AI indexing in progress, please wait!" (or something like that).

Given that it was useless, and I was getting constant emails about the index completing, and while the index was running constant emails about the system being "sluggish" - I've decided to uninstall Terra Photos and turn off all indexing.

freman wrote:
14 Sep 2022, 10:22
I'm gonna give up on terra photos for now.

It's quite unreliable, extremely slow, and did I mention quite unreliable.
Jay
---------------------------------------
F5-221, 5.0.171-00221
---------------------------------------

User avatar
criminal
Posts: 1
Joined: 05 Nov 2022, 06:05

Re: Terra Photos

Post by criminal » 05 Nov 2022, 06:14

JayBlingham wrote:
26 Sep 2022, 18:51
I 100% agree. I've really been trying to give it a fair shot but sending me a billion emails last night telling me the "media index is complete" was the last straw.

It did manage to complete an index of my nearly 50,000 pictures (roughly 82GB), and I was able to see the photos in the "Public" tab, but it was extremely slow to load even the first page of those photos and was completely unusable. I even gave it the benefit of the doubt and enabled the AI recognition to see if I could at least get those albums to work, which should (in theory) cause only a subset of the photos to load. I gave that over 5 days to run, and maybe it's because I'm running an older model (F5-221) but it always just kept saying "AI indexing in progress, please wait!" (or something like that).

Given that it was useless, and I was getting constant emails about the index completing, and while the index was running constant emails about the system being "sluggish" - I've decided to uninstall Terra Photos and turn off all indexing.

freman wrote:
14 Sep 2022, 10:22
I'm gonna give up on terra photos for now.

It's quite unreliable, extremely slow, and did I mention quite unreliable.
I have to agree with all of this and have no idea if this is just expected behavior.
It's crazy to me that just mapping the drive or photo directory to my windows machine is faster to browse through them just with windows explorer than with terra photos.
I'm very confused why it can't save or pre-generate most of the thumbnails? I indexed ~40k photos and it took awhile so why am I now having to very slowly scrolling through each in terra photos waiting for thumbnails?! Crazy slow when windows explorer beats it out.
I sincerely hoped I was just doing something wrong or missed an option for thumbnails during indexing or something but even with a very new system F2-221 and TOS 5 I can't understand what you could use this for. I tried smaller directories of only a few hundred images but the problems persist. Also it seemingly can't play .mpg files either which is disappointing.
Edit: I should add that the thumbnails that generate ARE NOT saved, you will be stuck scrolling slowly again as soon as you close and reopen Terra Photos...this can't be what's expected can it?

Post Reply