32-bit only?

Install virtual machines on your TNAS;
Post Reply
User avatar
datahorder
Posts: 6
Joined: 07 Jul 2020, 11:20

32-bit only?

Post by datahorder » 07 Jul 2020, 12:08

I only see the ability to use 32-bit operating systems on Virtual Box. But my NAS has an Intel® Celeron® J3455,
and its Processor Architecture is X.86 64-bit.

How can I allow for 64-bit OSs to be installed?

User avatar
TMSupport
Customer Service
Posts: 743
Joined: 13 Dec 2019, 15:15

Re: 32-bit only?

Post by TMSupport » 07 Jul 2020, 14:17

Please be noted that all X86 models including 220/221/421/422 are supporting VirtualBox. Only 210 model does not support VirtualBox at the moment.

Online
User avatar
TMroy
Customer Service
Posts: 745
Joined: 10 Mar 2020, 14:04

Re: 32-bit only?

Post by TMroy » 11 Jul 2020, 12:33

datahorder wrote:
07 Jul 2020, 12:08
I only see the ability to use 32-bit operating systems on Virtual Box. But my NAS has an Intel® Celeron® J3455,
and its Processor Architecture is X.86 64-bit.

How can I allow for 64-bit OSs to be installed?
As the VT-x feature has not been activated in previous models. To install a 64 bit OS in your VirtualBox, you need to enable this feature, here is what you need to do viewtopic.php?f=75&t=545
To contact our tech team or want a remote session, please email to support(at)terra-master.com

User avatar
datahorder
Posts: 6
Joined: 07 Jul 2020, 11:20

Re: 32-bit only?

Post by datahorder » 28 Jul 2020, 12:27

I'm using an F2-421.

I got the 64-bit OS options to show up using those steps. You also need to enable (for Intel x64):
VT-x (Intel Virtualization Technology) as well as VT-d.

But when I tried to create a new virtual disk it says:
terramaster vbox error.png


In the details it says:
Exception Object
(
[message:protected] => Could not create the medium storage unit '/home/VBox/Ubuntu1804/Ubuntu1804.vdi'.
VDI: disk would overflow creating image '/home/VBox/Ubuntu1804/Ubuntu1804.vdi' (VERR_DISK_FULL).
VDI: setting image size failed for '/home/VBox/Ubuntu1804/Ubuntu1804.vdi' (VERR_DISK_FULL)
[string:Exception:private] =>
[code:protected] => 0
[file:protected] => /mnt/md0/application/share/virtualbox/vbox/endpoints/lib/vboxconnector.php
[line:protected] => 5129
[trace:Exception:private] => Array
(
[0] => Array
(
[file] => /mnt/md0/application/share/virtualbox/vbox/endpoints/lib/vboxconnector.php
[line] => 951
[function] => remote_mediumCreateBaseStorage
[class] => vboxconnector
[type] => ->
[args] => Array
(
[0] => Array
(
[file] => /home/VBox/Ubuntu1804/Ubuntu1804.vdi
[type] => fixed
[size] => 10240
[format] => VDI
[split] =>
)

)

)

[1] => Array
(
[file] => /mnt/md0/application/share/virtualbox/vbox/endpoints/api.php
[line] => 316
[function] => __call
[class] => vboxconnector
[type] => ->
[args] => Array
(
[0] => mediumCreateBaseStorage
[1] => Array
(
[0] => Array
(
[file] => /home/VBox/Ubuntu1804/Ubuntu1804.vdi
[type] => fixed
[size] => 10240
[format] => VDI
[split] =>
)

[1] => Array
(
[0] => Array
(
[data] => Array
(
[responseData] =>
[success] =>
[key] => 53474945cfd7ac0bf8114767c209c2a6
)

[errors] => Array
(
)

[persist] => Array
(
)

[messages] => Array
(
)

)

)

)

)

)

)

[previous:Exception:private] =>
)


My disk isn't full, there's lots of space free.

User avatar
datahorder
Posts: 6
Joined: 07 Jul 2020, 11:20

Re: 32-bit only?

Post by datahorder » 08 Aug 2020, 04:03

Any insight into why I'm getting that error message?

User avatar
macmpi
Posts: 85
Joined: 07 Jan 2020, 02:52

Re: 32-bit only?

Post by macmpi » 08 Aug 2020, 16:18

Are you on btrfs?
I remember reading about some Virtualbox issues wrt btrfs...
TerraMaster F2-210 under TOS 4.1.30, RAID1, Btrfs, serving Mac, Linux & Windows clients

User avatar
TMSupport
Customer Service
Posts: 743
Joined: 13 Dec 2019, 15:15

Re: 32-bit only?

Post by TMSupport » 10 Aug 2020, 17:06

Is the former disk deleted yet?

User avatar
datahorder
Posts: 6
Joined: 07 Jul 2020, 11:20

Re: 32-bit only?

Post by datahorder » 08 Sep 2020, 07:31

Yeah, I'm using the default file system, btrfs

What's the 'former disk'? and how do I delete it?

Post Reply