Docker & Permissions (with SyncThing)

Discussion about Docker
Post Reply
User avatar
Solitude
Posts: 3
Joined: 28 Sep 2022, 08:13

Docker & Permissions (with SyncThing)

Post by Solitude » 02 Oct 2022, 23:13

TOS 5.0.171 is working here with the Docker app, and there is a SyncThing docker repository image that seems to function, except that the directory which I chose for mounting the container seems not to allow my application to have permissions. Must I change the permissions for the specific directory? Should I make a usergroup and add docker or syncthing and give it permissions on my volume? What permissions should I put on my directory so that my docker syncthing can have read/write access?

User avatar
TMSupport
Customer Service
Posts: 2145
Joined: 13 Dec 2019, 15:15

Re: Docker & Permissions (with SyncThing)

Post by TMSupport » 03 Oct 2022, 17:02

Please check if the configuration of the container is correct?
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
Solitude
Posts: 3
Joined: 28 Sep 2022, 08:13

Re: Docker & Permissions (with SyncThing)

Post by Solitude » 05 Oct 2022, 06:27

Yes. Something is wrong with the container settings. I make a mount folder and I am sure not to check the box for "read-only". However, later when I run the container and look at the information, it appears that the read-only attribute have been selected somehow. What is happening?

Image

User avatar
Solitude
Posts: 3
Joined: 28 Sep 2022, 08:13

Re: Docker & Permissions (with SyncThing)

Post by Solitude » 05 Oct 2022, 22:50

Okay! I think that I figured it out!

First, the Read-Only attribute isn't getting set automatically until you stop the container. Before restarting, you have to unselect it, maybe as a safety precaution?

Second, I had success with the repository image labeled "syncthing/syncthing". In the setup, it sets a group-id as 1000. I had to use ssh to set the group of the directory where my sync will go, so that it matches the variable in the container setup. Presto! Now syncthing runs without complaining about permissions denied.

Post Reply