Time Machine backup not working on TOS 5 with a MacOS Catalina client

Backup and restore solutions, issues, experiences
Post Reply
User avatar
gmanghi
Posts: 2
Joined: 04 Aug 2022, 15:40

Time Machine backup not working on TOS 5 with a MacOS Catalina client

Post by gmanghi » 04 Aug 2022, 15:53

Hi,

I have upgraded to TOS 5 on a F2-422 device and noticed that Time Machine backup is not working when using a macOS Catalina (Mac Mini late 2012) client. There is no error message, the backups starts but then ends without any error but being incomplete.

Interestingly it works ok if using a macOS Monterey device (Mac Mini M1 2020).

I downgraded to TOS 4 (because TOS 5 has many issues) and in both cases Time Machine works as expected.


There is also an issue in TOS documentation about Time Machine:

here https://www.terra-master.com/time_machine_backup (and as well in the docs page/site that opens from within TOS 4/5) is referred to "Set "Authorized User". Users who are not on the "Authorized User" list will not be able to use this feature;" but this is something that existed in TOS 3, not 4 or 5 as far as I understand. There is no "Authorized User" option when setting up Time Machine folders in TOS 4 or 5.

Instead it should be referred that any users with write permission in the shared folder being set up for Time Machine backups can be used. but is **important** to refer that at least in TOS 5 the default user (the one set up during TOS installation) can't be used as it won't work on macOS side!

User avatar
Charlie_Croker
Posts: 100
Joined: 07 Oct 2020, 19:05

Re: Time Machine backup not working on TOS 5 with a MacOS Catalina client

Post by Charlie_Croker » 06 Aug 2022, 19:18

{L_BUTTON_AT}gmanghi
Thanks for the info, I can confirm it works brilliantly on M1 Macs with Ventura. That 2012 Mini is now 10 years old (one of the good things about Macs is they last forever, I only recently got rid of a Mac Pro 4,1 (flashed to 5,1) 12 core Xeon 3.46GHz, with 24GB RAM and for a Mac built in 2009 was still going strong, only the SATA 2 & USB 2 (I had PCI-E cards for SATA 3 and USB 3). Its still in use with a design/print company :)
Ex Terramaster user. British citizen, Ex resident of KSA, USA and now in UAE.

User avatar
TMroy
Customer Service
Posts: 1777
Joined: 10 Mar 2020, 14:04

Re: Time Machine backup not working on TOS 5 with a MacOS Catalina client

Post by TMroy » 07 Aug 2022, 12:38

{L_BUTTON_AT}gmanghi
Did you try time machine backup via SMB or AFP? or you tried both? if one of the file service not work, please try another. Remember to enable the
AFP file service because it is disabled by default in TOS 5.

We will update the documentation recently, thank you for your report.
To contact our team, please send email to following addresses, remember to replace (at) with @:
Technical team: support(at)terra-master.com (for technical support only)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
gmanghi
Posts: 2
Joined: 04 Aug 2022, 15:40

Re: Time Machine backup not working on TOS 5 with a MacOS Catalina client

Post by gmanghi » 08 Aug 2022, 17:41

{L_BUTTON_AT}gmanghi
TMroy wrote:
07 Aug 2022, 12:38
Did you try time machine backup via SMB or AFP?
I had both enabled.

Post Reply