TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Discuss or report issues regarding TOS updates or beta releases
User avatar
TMSupport
Customer Service
Posts: 1459
Joined: 13 Dec 2019, 15:15

TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by TMSupport » 12 Apr 2021, 15:50

Update notes for TOS_PATCH_ARM_1.06

Release Notes:
. Fixed vulnerabilities in Rsync;
. Fixed vulnerabilities in UPnP;

Applicable models:
ARM:
F2-210、F4-210
x86:
F2-220、F2-221、F2-420、F2-421、
F4-220、F4-221、F4-420、F4-421、
F5-220、F5-221、F5-225、F5-420、F5-421、F5-422、
F8-421、F8-422

Applicable TOS
TOS4.2.06, TOS4.2.07, TOS4.2.08, TOS4.2.09.

Download link:
For ARM models: https://download2.terra-master.com/TOS_ ... M_1.06.bz2
For X86 models: https://download2.terra-master.com/TOS_ ... 4_1.06.bz2

How to install the patch?
1. Go to TOS> Control Panel> General Settings> Update & Restore, and click “Manual Update”;
2. Click "Browse" to select the downloaded patch package;
3. Click "Apply";
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
sianderson
Posts: 293
Joined: 02 Aug 2020, 03:42

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by sianderson » 12 Apr 2021, 21:54

perfect upgrade thank you nice and simple
F2-210

4.2.16

User avatar
shabbirh
Posts: 1
Joined: 14 Apr 2021, 17:11

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by shabbirh » 14 Apr 2021, 17:35

Hi,

Thanks this updated worked perfectly (F4-210 (ARM)).

Just wanted to make a quick point for any one else who once the NAS comes back on line find that their shared folders are unavailable. This is because you have chosen encryption (always a good thing). You just need to go into the Web Interface and enter the encryption key/password for your given share and it will mount.

Thanks again, and looking forward to the upcoming 4.2.12 update (for ARM).

Peace

User avatar
Gandalf1369
Posts: 37
Joined: 26 Feb 2020, 01:34

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by Gandalf1369 » 17 Apr 2021, 02:54

Installed the 1.06 (X86 version) patch on my F4-220 running the latest TOS 4.2.09. Smooth and quick upgrade with no problems. Thank you . . .
F4-220 with 4x5TB drives

User avatar
pinuk
Posts: 10
Joined: 04 May 2020, 23:25

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by pinuk » 01 May 2021, 23:32

The link seems to be unavailable, is there an alterative download location for this?

Thanks.

User avatar
TMRyan
Customer Service
Posts: 547
Joined: 01 Dec 2020, 11:50

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by TMRyan » 02 May 2021, 00:22

{L_BUTTON_AT}pinuk
Hi,
The link is available, you can try to check the network, browser settings or firewall.
To contact our team, please send email to following addresses, remember to replace (at) with @
Technical team: support(at)terra-master.com (for technical support)
Service team: service(at)terra-master.com (for purchasing, return, replacement, RMA service)

User avatar
sc351
Posts: 9
Joined: 19 Dec 2020, 13:36

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by sc351 » 05 May 2021, 21:18

This patch would render my f4-210 TOS UI useless after about 10 minutes. I've reverted back to patch 1.04 and operation is back to normal.

User avatar
sianderson
Posts: 293
Joined: 02 Aug 2020, 03:42

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by sianderson » 06 May 2021, 15:32

sc351 wrote:
05 May 2021, 21:18
This patch would render my f4-210 TOS UI useless after about 10 minutes. I've reverted back to patch 1.04 and operation is back to normal.
thats interesting my F2-210 has been running for 24 days straight without any problems with this patch, what kind of things do you run on it? i have DLNA Media Server, One Drive and USB Copy
F2-210

4.2.16

User avatar
victorjhg
Posts: 2
Joined: 06 May 2021, 16:20

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by victorjhg » 06 May 2021, 16:31

Yesterday I installed the update on an F5-422 with 4.0.9-P1.04 and since then I have a nice "502 - Bad Gateway" error. No access to the web locally or to files remotely. Nice job. To reinstall ...

User avatar
victorjhg
Posts: 2
Joined: 06 May 2021, 16:20

Re: TOS Patch1.06 for ARM/X86 models for TOS4.2.06~4.2.09

Post by victorjhg » 06 May 2021, 16:51

victorjhg wrote:
06 May 2021, 16:31
Yesterday I installed the update on an F5-422 with 4.0.9-P1.04 and since then I have a nice "502 - Bad Gateway" error. No access to the web locally or to files remotely. Nice job. To reinstall ...
Ok, I was going to reinstall the system following the instructions available at viewtopic.php?f=75&t=423 and at the beginning of the process indicates that the data on the HDDs will be erased. Please help!!!

Locked