Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

SMB/CIFS, NFS, AFP, FTP, HTTP file service and Rsync server.
Post Reply
User avatar
clapper66
Posts: 3
Joined: 10 Jun 2021, 02:47

Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by clapper66 » 10 Jun 2021, 03:55

So, I currently have windows server 2019 running an older dell power edge R720. It is running the filesharing and a domain roles. Tuesday, I got my F2-210 in the mail and yesterday got brand new 4TB WD RED NAS drives. I installed the drives, and then went onto configure TOS on the NAS with an Admin user and a user to connect to shares and made a share that the Admin and the user had full access to. Also, I went into the file settings and ensured SMB was enabled, and tied turning it off and back on. After this I went to file explore on my server and typed into the path \\192.168.1.153\Backup. Half the time it will pop up a box asking for credentials and other times just give me a connection error. When the credentials window did pop up it took me a couple tries to get it to accept the credential and allow me in. I ended up having to use (Server_NAME)\(NAS_USER) in the user name field. Example Server2019\Admin to get the NAS to allow me into the share. The problem is even with the credentials temporarily cached or saved in windows credential manager the SMB connection is temperamental. Some times it connects other times it does not or it does not take the saved credentials and asked for credentials.

All I’m trying to do is use the NAS to do daily Backups of my server’s OS and my file with Symantec System recovery. I work in IT and have worked with multiple Synology, and Q NAP NAS models with no issues at all to accomplish the same task. The F2-210 NAS isn’t a powerful NAS and I wasn’t expecting much from it besides using it to backup files once a day and cannot seem to accomplish this, and I got it on sale from newgg for $120. At this point I’m I have looked online and seen other users report the same problems with TereaMaster NASs. If I cannot get this to work tonight, I will be looking into Returning the TerraMaster NAS to Newegg and look at a Qnap or Synology NAS.

User avatar
TMSupport
Customer Service
Posts: 1282
Joined: 13 Dec 2019, 15:15

Re: Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by TMSupport » 10 Jun 2021, 14:35

Hello, it's usually the reason of the password if your credentials are not accepted. There should be special characters in the password.
While it seems that you can connect sometimes, not so sure what's the reason for it. Please advise your current TOS version in return.
The TOS4.2.13 is released, please update to this version to see if anything better.
To contact our tech team, please email to support(at)terra-master.com, remember to replace (at) with @

User avatar
clapper66
Posts: 3
Joined: 10 Jun 2021, 02:47

Re: Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by clapper66 » 11 Jun 2021, 04:48

Unfortunately I dot not know the exact TOS version on the device. It was 4.2.Something . When making the passwords I tried something simple like Abc123456789 and a complex password with upper case and lower case characters and special characters neither seems to work. Unfortunately after spending hours trying to make this NAS work i ended up giving up. I tried all that and a factory reset to the NAS and made its name completely different along with the usersnames and passwords. Also I tried a DHCP IP and set a IP static outside of my DHCP scope and neither helped.

At the IT company I work for we have a used Qnap NAS sitting around from some client who did not need it anymore. I asked my boss if I could take it and try it at home and got the okay. I took it home and set it up and it worked! This confirmed to me that there issues lies with the TerraMaster NAS and not my server or network equipment.

I seen TerraMaster as the underdog company in NAS market that is looking to give users the most they can for their money and wanted to give it a chance. Also i was willing to try it because Newegg had the NAS on sale for $120. Unfortunately it did not work out for me. I looked at this NAS as a lower end Spec NAS that couldn't do as much like use apps like PLEX, but overlooked this because my plan was to just use the nas a a location to save image backups of my server. Unfortunately I couldn't not accomplish this simple task with this NAS and have done a RMA with newegg and bought a Synology NAS.

User avatar
TMSupport
Customer Service
Posts: 1282
Joined: 13 Dec 2019, 15:15

Re: Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by TMSupport » 11 Jun 2021, 10:37

We could help you with remote session to check what's the exact issue and reason there if it's ok for you.If it's the issue of our NAS or we can't fix it, you can return it to Newegg.
To contact our tech team, please email to support(at)terra-master.com, remember to replace (at) with @

User avatar
TMroy
Customer Service
Posts: 1213
Joined: 10 Mar 2020, 14:04

Re: Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by TMroy » 12 Jun 2021, 14:52

Your issue is most likely caused by the incompatibility between the SMB version of your old dell server and the SMB version of TNAS. Please check the version of your server and configure the SMB version in SMB advanced settings.
To contact our tech team, please email to support(at)terra-master.com, remember to replace (at) with @

User avatar
clapper66
Posts: 3
Joined: 10 Jun 2021, 02:47

Re: Cannot connect consistently with SMB trough file explorer my windows server 2019 . NAS MODEL F2-210

Post by clapper66 » 16 Jun 2021, 06:30

TMroy wrote:
12 Jun 2021, 14:52
Your issue is most likely caused by the incompatibility between the SMB version of your old dell server and the SMB version of TNAS. Please check the version of your server and configure the SMB version in SMB advanced settings.
I did check the setting and turned SMB 1.0 on and got it to work sort of. It seems to connect and sometimes work but other times did not.

Either Way I do not want to use a older unsecure version of SMB to accomplish my task. unfortunately the nas has been sent back to Newegg, and I have gone ahead and purchased and setup my Synology NAS and have it working.

Post Reply